Басты бет » 2015 » Январь » 19 » POWER POINT ЖӘНЕ EXCEL БАҒДАРЛАМАЛАРЫНДА ТЕСТ БАҒДАРЛАМАСЫН ҚҰРАСТЫРУ
17:28
POWER POINT ЖӘНЕ EXCEL БАҒДАРЛАМАЛАРЫНДА ТЕСТ БАҒДАРЛАМАСЫН ҚҰРАСТЫРУ
загрузка...

POWER POINT ЖӘНЕ EXCEL  БАҒДАРЛАМАЛАРЫНДА  ТЕСТ БАҒДАРЛАМАСЫН ҚҰРАСТЫРУ

Нигметова Венера Курманбаевна

Құрманғазы ауданы

Сафон селосы

Ф.Энгельс атындағы орта мектебі

 

Қазіргі кезде компьютерді пайдаланып оқушыларды тоқсан ішінде бірнеше рет тестілеу - олардың ағымдық білімін бағалаудың негізгі әдістерінің бірі. MS Office өнімінің  Power Point және Excel электрондық кестесі –мұғалімге оқушы білімін тексеруге және оқушының өзбетімен жұмыстануына тест бағдарламасын құруда ең қажетті әрі жеңіл бағдарламалар деп санаймын. Сондықтан да Power Point- та Visual Basic программалау тілінің   мүмкіндіктерін  және Excel электрондық кестесінде формулаларды қолданып бірнеше сұрақтан тұратын тест бағдарламасын құрастырып  шықтым.

Бағдарламалық өнімдерді құрастырудағы мақсатым –  мұғалімдерге жүргізілетін пәндері бойынша тексеру  тестін жүргізуде   көмек көрсету. Әр түрлі пәндер бойынша оқушыларға тест жұмыстарын тез әрі өз бетінше құруға көмектеседі.

Тест қорытындысы  оқушының берген жауабына қарай ұпай және бағамен көрсетіліп отырады.

Қазіргі кезде дербес компьютерлерді пайдаланушылар арасында Windows  операциялық жүйелері жанұясы танымал және бағдарлама жасауға қызыққандар, осы жүйеде жұмыс жасайтын бағдарламалар жазуға ынталанады. Бұл күнделікті өмірге ақпараттық технологиялардың  енуімен және дамуымен байланысты. Егер де адам компьютермен жұмыс жасаса, онда ол адамда ерте ме, кеш пе ынта, кейбір кездері бағдарламаларды үйрену қажеттілігі туындайды.

Есептеуіш техниканың дамуы, бағдарламаны қамтамасыз жасау  құралдарына деген эффективті қажеттілік, бағдарламалау тілдерінің пайда болуына әкелді, олардың ішінде келесілерді  Borland Delphi  және  Microsoft  Visual Basic көрсетуге болады.  Тез жасау жүйесінің негізіне көрнекі жобалау технологиясы және оқиғалы  бағдарламалау жатады.

Microsoft  Visual Basic Windows –қа кәсіби деңгейлі интерфейсі бар қолданбалы бағдарлама жасауға мүмкіндік береді.

            Осы жобада программаларды тестілеу Visual Basic  бағдарламалау ортасының мүмкіндіктері арқылы жүзеге асады.

  Мақсатым - Visual Basic визуалды  жобалау ортасында мектепте программаны тестілеу бағдарламасын құру болып  табылады. Тест оқушы білімінің деңгейін ғана анықтап қана қоймайды, оның ойын жүйелеп, жылдам есептеуіне, логикалық ойлау, есептеу дағдыларының қалыптасуына, тез шешім қабылдау қасиетінің дамуына тиімді әсер етеді. Тест оқушының білім дәрежесін қандай екендігін анықтайтын және ол білімді түрлі жағдайларда қолдана білуін тексеруге мүмкіндік беретін тиімді жол.

І. Power Point- та Visual Basic-тің  көмегімен тест құрамыз. Ол ұшін жаңа презентация құрамыз. Power Point параметрлері батырмасынан Разработчик менюін  шығарып аламыз.  (1 сурет)

Visual Basic-тің көмегімен әр түрлі типті сұрақтарды, яғни бір жауапты таңдау, жауапты ұяшыққа енгізу, бірнеше жауапты таңдау мүмкіндігін беретін тест құрастыруға болады. Тест жауаптарын батырма, жалауша немесе  қосқышты шерту арқылы таңдауға болады.

 

Батырманы редакторлеу және программа жазу үшін батырма үстіне екі рет шертеміз.  microsoft Visual basic терезесі ашылады. Келесі функцияларды қараймыз: Caption – батырма аты.  CommandButton өшіреміз де өзімізге қажетті аты енгіземіз. Мысалы "1".  Font режимінде батырмадағы әріп өлшемі мен стилі қойылады.

  (3 сурет)

Программасы:   n – сұрақтар санын санайтын айнымалы, k – дұрыс жауаптар санын санайтын айнымалы. Бұл бірінші сұрақ болғандықтан, оларды 0 –ге тең деп береміз. K дұрыс жауаптар батырмасын,  ал  n әрбір жауцаптар батырмачсын басқанда өсіп отырады. MsgBox ол тырнақшаға алынған мәтінді қосымша терезеге шығаратын команда. SlideShowWindows(1).View.Next командасы мәтінді жаңа слайдқа аударады.

 

Сұрақтарды қарапайым режимде жазып, дұрыс жауаптарды таңдау үшін  Қосқышты (переключатель) қосамыз. Батырманы қосу мысалындағыдай, Қосқышты жазамыз. Тағы да «Жауапты қабылдау» деген батырманы қосамыз да оны да өңдеп жаңа слайдқа көшеміз. (3 слайд)

Батырмаға екі рет шертіп программа терезесін шақырамыз.төмендегі программаны жазамыз

 

3 сұрақтың жауабын енгізу  үшін  «Өріс» батырмасын таңдаймыз. Тағы да «Жауапты қабылдау» деген батырманы қосамыз да оны да өңдеп жаңа слайдқа көшеміз. (4 слайд)

 

Бірнеше жауапты таңдауға болатын слайд құраймыз. Ол үшін Разработчик панелінен «Жалауша» батырмасын қойып, жоғарыдағы мысалдардай жауаптарды жазамыз. (5  слайд)

 

Суретті таңдауға болатын слайд құрамыз. Разработчик панелінен  батырмасын таңдап суреттерді кірістіріп, өңдейміз. (6 слайд)

 

Тест жауабын өңдейтін форма құрамыз. Мәтіндерді қарапайым режимде енгізіп, нәтижені көрсететін батырмаларды қосамыз.  Нәтижені көрсету үшін «Нәтиже» батырмасын қосамыз. (7 слайд)  

ІІ. Excel электрондық кестесінде формулаларды қолданып тест құраймыз.

Үлгі бойынша тапсырма мәтінін тереміз. А бағанына тест сұрақтары мен жауаптарын енгіземіз.

  1. В29 ұяшығына барлық жауаптарды санайтын формцула енгіземіз. =СУММ(B6:B24) 
  2. С29 ұяшығына дұрыс жауаптарды  санайтын формула енгіземіз. =B8+B14+B17+B22
  3.  D29 ұяшығы Формат Число Процентный =ЕСЛИ(B29=4; C29/B29;)
  4. Бағаларды көру үшін В32 ұяшығына =ЕСЛИ(D29>=80%; "5";"  ") формуласын,  С32 ұяшығына =ЕСЛИ(И(D29<80%;D29>=60%);"4";"  ")формуласын,  D32 ұяшығына =ЕСЛИ(И(D29<60%;D29>=40%);"3";"  ") формуласын,  Е32 ұяшығына =ЕСЛИ(И(D29<40%; D29>=0%); "2";"  ") формуласын енгіземіз.

Бағалау шкаласы (әркім өз қалауымен өзгерте алады)

«5» - 80-100%, «4» - 60-79%,«3» - 40-59%, «2» - 0-39%

Тестті қолдану: В бағанына дұрыс жауаптардың тұсына 1 санын енгіземіз.

loading...

Авторы:

Бөлім: Баяндама | Көрсетілім: 1363 | Қосты: Venera79 | Ілмек сөздер: POINT ., POWER | Рейтинг: 0.0/0
Барлық пікірлер: 0
Пікірді тек тіркелген қолданушылар ғана қалдыра алады
[ Тіркелу | Кіру ]
Іздеу
Сертификат алу
Бөлімдер
Ұстаздарға
Ата-аналарға
Біздің мектеп
Баяндама
Эссе
Оқушыларға
Конкурс ең үздік шығарма
Ең үздік шығарма конкурсына арналған. Шығармаларды осы жерде жазамыз
Сайтқа кіру
Логин:
Пароль:
Күнтізбе
«  Январь 2015  »
ПнВтСрЧтПтСбВс
   1234
567891011
12131415161718
19202122232425
262728293031
Жазба мұрағаты
Сұрақ
Сізге сайттың жаңа дизайны ұнады ма?
Барлық жауаптар: 5904
Бізге қосыл
Жаңалықтар
Санақ

Онлайн: 15
Қонақтар: 15
Тіркелгендер: 0